Back to all threads

LPC1343 Codebase won't build!

Post reply

Leon  Heller
(2 posts)

Posted: 14 Apr 2012, 10:04

I get this error when building the Codebase with CrossWorks:

Building “LPC1343_CodeBase” in configuration “THUMB Flash Release”
  Compiling adc.c
  Compiling cpu.c
  Compiling gpio.c
  Compiling pmu.c
  Compiling ssp.c
  Compiling timer16.c
  Compiling timer32.c
  Compiling uart.c
  Compiling uart_buf.c
  Compiling usbconfig.c
  Compiling usbhid.c
  Compiling wdt.c
  Compiling systick.c
  Compiling i2c.c
  Compiling iap.c
  Compiling cmd.c
  Compiling cdcuser.c
  Compiling usbcore.c
  Compiling usbdesc.c
  Compiling usbhw.c
  Compiling usbuser.c
  Compiling cdc_buf.c
  Compiling pwm.c
  Compiling lm75b.c
  Compiling tsl2561.c
  Compiling tcs3414.c
  Compiling st7565.c
  Compiling ssd1306.c
  Compiling sharpmem.c
  Compiling ILI9328.c
  Compiling dejavusans9.c
  Compiling dejavusansbold9.c
  Compiling dejavusanscondensed9.c
  Compiling dejavusansmono8.c
  Compiling dejavusansmonobold8.c
  Compiling veramono9.c
    C:/Users/Leon/Desktop/LPC1343_CodeBase_v1.1.0/build/crossworks/../../drivers/displays/tft/fonts/veramono9.c: No such file or directory
    compilation terminated.
Build failed

The previous version 0.95 wouldn't build either, because of a different missing file!

Reply

microBuilder 
Administrator
(136 posts)

Posted: 14 Apr 2012, 12:04

Leon:

Thanks for the heads up.  It's been fixed, and the changes pushed to Github and the download file stored here locally has also been updated (v1.1.1 for the LPC1343).  Caught a problem with the LPC1114 Codebase as well.  Shame on me for only testing with the local dev dir, not from the downloaded source from the repository. :)

Reply

Leon  Heller
(2 posts)

Posted: 15 Apr 2012, 09:04

microbuilder said:

Leon:

Thanks for the heads up.  It's been fixed, and the changes pushed to Github and the download file stored here locally has also been updated (v1.1.1 for the LPC1343).  Caught a problem with the LPC1114 Codebase as well.  Shame on me for only testing with the local dev dir, not from the downloaded source from the repository. :)
Thanks. The new version is OK.

Reply

bobc 
(2 posts)

Posted: 25 May 2012, 11:05


FYI I get a "missing file" error : ina219.c with the Crossworks project.

Reply

Post reply